The VIPER Garage
User Info
Welcome, Guest. Please login or register.
December 15, 2018, 02:44:54 PM

Login with username, password and session length
Search:     Advanced search
News
Pick Your ViperGarage Theme
Forum Stats
24622 Posts in 1936 Topics by 842 Members
Latest Member: XEvilBestSaw
Home Help Search Calendar Login Register
The VIPER Garage  |  Generation-specific Viper Forums  |  RT/10 & GTS Viper Discussions  |  Front mount twin turbo all out build
« previous next »
Pages: 1 ... 4 5 [6] Go Down Print
Author Topic: Front mount twin turbo all out build  (Read 8832 times)
jtin
Jr. Member
**
Offline Offline

Posts: 663


« Reply #75 on: February 10, 2017, 11:43:51 PM »


Here was the one issue I did find. Right in the middle of the valves there is paper thin aluminum and same on the one side of the plug hole. This was causing boost issues and giving misfires. Took the heads to get debured (should have done this when they were new) and gave them a new valve grid.



Rod bearings once again looking fresh. Didn't even wear off the coating. I did replace these as I was already there and they are a cheap part to replace. But could have easily ran them another season.


Wrapped the logs and also added vbands for easier maintenance in the future.


Safety wired the log bolts. Had some come lose on me during the summer.

Logged
jtin
Jr. Member
**
Offline Offline

Posts: 663


« Reply #76 on: February 10, 2017, 11:58:54 PM »


New filters that are much better fitting and more possible total cfm's


Forgive the dirty car as its under some fab work at this point. Built an air box for testing some of the air temps to see if it makes any difference.


Air box lid. None of this stuff is final product until it proves itself to be effective via data.



Logged
jtin
Jr. Member
**
Offline Offline

Posts: 663


« Reply #77 on: February 11, 2017, 12:04:30 AM »


Cooked the coolant pressure tank......Also the blower motor.





Logged
jtin
Jr. Member
**
Offline Offline

Posts: 663


« Reply #78 on: February 11, 2017, 12:10:25 AM »


Built some shrouds for the heat exchangers. These will force the air to have to go through the cores. Again just some prototype stuff to see if they make any differences.



« Last Edit: March 06, 2017, 03:31:24 PM by jtin » Logged
jtin
Jr. Member
**
Offline Offline

Posts: 663


« Reply #79 on: February 11, 2017, 12:20:30 AM »


Here are so more air flow cooling testing stuff i'm trying out.

Now waiting to decide what I'm doing for a trans, T56 has no chance with 4000 lbs car with a 3.0 rear end gear and 5500 rpm clutch dumps...........
Logged
RTTTTed
Owner
Administrator
Hero Member
*****
Offline Offline

Posts: 7725


Viper Nation - ezine
« Reply #80 on: March 07, 2017, 11:11:27 PM »

Looking great Joel.  Waiting for Transmission pics.  Since you're signed in to the June Halfmile ...
Logged
1999 1200rwhp TT GTS - ART, 2001 Roe sc GTS- (4 sale), 440 Duster restomod (sold), 3x Stealth TTs, 92 Daytona IROC with T3, 580whp/1080wtq Cummins pickup.
jtin
Jr. Member
**
Offline Offline

Posts: 663


« Reply #81 on: June 22, 2017, 06:15:04 PM »

Well I got the TH400 in the car and went 9.6@144@10psi.

Still lots of data to be collected but heading in the right direction after a painful last few months trying to find multiple issues.

The trans has been flawless.  Wish I bought it the day I bought the car. It has surpassed all my expectation and makes a 6 speed a thing of the past for me personally.
Logged
RTTTTed
Owner
Administrator
Hero Member
*****
Offline Offline

Posts: 7725


Viper Nation - ezine
« Reply #82 on: July 21, 2018, 12:21:31 PM »

Awesome work Joel.  Lots of good information in this thread!  You ran a 8.7@ 160mph last year didn't you?

After busting my GForce 1200hp rated T56 I started a Lenco build.  Purchased Lenco and Gear Vendor.  Requires custom slipper clutch and custom made bellhousing etc so I put that on hold for awhile

I was offered a deal on a T400 "kit" and I bought it for half price.  It's a 1200hp build so I'll keep my boost low until I build a new tranny or go back to my Lenco project.

We ran 9.3@169mph on a drag day at Castrol Dragstrip in Leduc!  Car squated and rolled out 300' before cleaning out and running hard.  They kicked us off the track before we got to actually get a good run in.

Gonna be killer once you get it sorted out.  Roll bar and chute installed now.
Logged
1999 1200rwhp TT GTS - ART, 2001 Roe sc GTS- (4 sale), 440 Duster restomod (sold), 3x Stealth TTs, 92 Daytona IROC with T3, 580whp/1080wtq Cummins pickup.
jtin
Jr. Member
**
Offline Offline

Posts: 663


« Reply #83 on: July 21, 2018, 07:41:07 PM »

Yes the car has had a few major changes. The engine and turbo system remain the same. 

As far as the drags go it went 8.7 @ 163 and 9.20@168.
Returned short after that and it went 10.0 @ 169 with bad O2 sensor missing out on the first 300 feet.
Recently went back out and ran 9.20@160 blowing tires at 100ft Mark and lifted a head on that pass. 

It’s currently being rebuilt and by mid August I’d like to run a clean pass from beginning to end.  Hoping for 8.50’s at 170 plus. See what happens.
Logged
Pages: 1 ... 4 5 [6] Go Up Print 
« previous next »
 

SMF 2.0.2 | SMF © 2011, Simple Machines | Theme by nesianstyles | Buttons by Andrea